Documentation‎ > ‎User Manual‎ > ‎

Animation View and Animation Inspector

In an Animation, a sequence of images is displayed to give the illusion of movement. In ParaViewGeo you have several animation options which relate to changing the parameters of objects (such as readers, filters, sources or even the camera) over time. You can:
  • Create a camera animation; the objects remain unchanged, but the camera viewpoint changes throughout
  • Animate almost any property of any object in the pipeline
  • Load a file containing data that changes over time
  • Load a file series; the numbering on the file names indicates that it is an animation

You could even combine some of the above options.

The VCR Controls toolbar is used to control the running of the animation and the Animation View window is used to create and modify animations.


Contents

Playing an Animation

The VCR Controls toolbar is used to navigate through an animation. All the required functions are available through the buttons located here.


The First Frame and Last Frame buttons will display the beginning and end of the animation respectively, and the Next Frame and Previous Frame buttons will move through the animation one frame at a time.

When the Play button is initially pressed, the animation will start from the beginning and two new buttons appear on the toolbar, while Play disappears temporarily. One of these is a Pause button which will pause the animation at its current frame. Pressing the Play button again will resume the animation from the frame where it was paused. The second button that appears is the Stop button, which stops the animation at the current frame. Pressing the Play button when the animation is stopped will restart the animation from the beginning.

The Loop button will cause the animation to replay over and over again until either Pause or Stop are pressed.


The Animation View

In order to create or modify an animation, the Animation View window must be visible. This window can be turned on from the View menu and will appear below the View Manager.

The top of the window contains five fields; Mode, Time, Start Time, End Time and No. Frames / Duration.

Three modes are available in the Mode drop-down; Sequence, Real Time and Snap To Time Steps.

The Sequence mode plays the animation in a sequence of frames, one after the next, until the specified number of frames is reached. When this mode is selected, the Time, Start Time, End Time and No. Frames fields are available. The Start Time and End Time show the length of the animation and the Time field shows the current time of the view that is visible. The No. Frames field shows the total number of frames that make up the animation. In Sequence mode, the frames are rendered as quickly as possible; the time fields don't necessarily relate to actual seconds.

The Real Time mode relies on a duration (in seconds) over which the animation runs. This mode uses the Time, Start Time, End Time and Duration fields. The Start Time and End Time show the length of the animation and the Time field shows the current time of the view that is visible. The Duration field indicates the number of seconds for which the animation will play. The time fields don't necessarily relate to actual time steps.

In the Snap To Time Steps mode the number of time values in the dataset determines the number of frames in the animation. This is the type of animation that is used by default when a dataset with time values is loaded into the pipeline. When this mode is selected, the other fields in this row are not available.

The lower section of the Animation View shows the Tracks that exist. If the dataset contains time or if a file series is loaded, only the Time and Timekeeper -Time tracks are shown. When animations are created, additional tracks will indicate which parameters of which objects are being animated. The black bar in the track is linked to the Time field at the top and indicates the time of the view that is visible in the render view.

Tracks are created using the two drop-downs at the bottom of the window. The first drop-down lists all available objects, and the second drop-down lists the properties that can be animated for the selected object. Once the correct combination is selected, clicking on the Plus button will add the track to the window. A track can be removed by clicking the red X button beside the track.


Tracks are made up of Animation Keyframes. Double-clicking on a track opens the Animation Keyframes window which displays all the keyframes that exist for that track. The three buttons on the right allow you to create New keyframes, Delete the currently selected keyframe, or Delete All keyframes. By default, when selecting New, a keyframe is added immediately in front of the currently selected keyframe (or in front of the last keyframe if none are selected). Also by default, the Time of the new keyframe will be set half-way between the previous and following times (i.e. if there are 2 keyframes with time 0 and 1, adding a keyframe will default to time 0.5).

Since the editing of keyframes depends on the type of animation, the edit options are covered below with the respective animation type.


Camera Animations

In a Camera Animation the view angle of the camera changes over time. Camera animations usually use either the Sequence or Real Time modes.

A camera animation is created by choosing the Camera in the object drop-down and clicking the plus icon to add the track; there are currently no camera properties available, so that drop-down is grayed out.

Keyframes for camera animations are comprised of a Time and a Camera Value. The Time of a keyframe can be manually changed by double-clicking on the value and entering the new value. Double-click on one of the Camera Value Positions to open the Keyframe Interpolation window. The Camera Value can be changed in two ways; by manually entering the camera values, or by changing the camera viewpoint in the render view and using the Use Current button which will copy the values from the current camera settings.

Note: Up to version 1.4.13, the camera position values cannot exceed 10000 in the three dimensions. This bug is fixed in version 1.4.14, but since the Brunswick mine data is located above 10000, it is not possible to create a camera animation for the demo data with earlier versions.


Property Animations

Almost any property for any pipeline object can be animated. Property animations usually use the Sequence or Real Time modes.

To create a property animation, select the object from the drop-down and then choose the property you want to animate. Visibility and Opacity are available for all options, and Source objects usually have all properties from the Object Inspector available. If you want to animate a reader's property, you may have to apply a filter and then animate the filter instead. For example, to animate an object by one of its scalar arrays, apply a threshold filter to the dataset using that array. Then select the threshold object in the animation drop-down and create the animation that way.

The animation keyframes of property animations generally consist of Time, Interpolation and Value. The Time value can be manually changed by double-clicking on a value and entering the new one.

There are four types of Interpolation that can be used; Linear, Exponential, Sinusoidal and Step. Double-clicking in the Interpolation column will open the Keyframe Interpolation window, where the types are available from a drop-down. The Linear option will linearly interpolate from one frame to the next. When the Exponential option is selected, a specified exponential function is used to interpolate between frames. The Base, Start Power and End Power have to be entered. The Sinusoidal option will use a specified sine function to interpolate the values from one frame to the next. With the Step option, a frame is displayed until the time for the next frame is reached.

The property Value can be edited by double-clicking on one of the values and entering the new value.


Datasets changing over time

Some datasets already contain properties that change over time when they are loaded into ParaViewGeo. The Time section on the Information tab in the Object Inspector lists the time values that exist.

These datasets default to the Snap To Time Steps mode, and usually no other steps are required; the animation can be played using the Play button on the VCR Controls toolbar. The animation will display each time step contained in the dataset.

The playback mode can be changed to Sequence or Real Time to activate their related properties (number of frames, duration). Maybe the time intervals of the animation are not even; changing the mode allows control of the time and speed of the animation. For instance, when the mode is changed to Real Time, all the frames will be displayed within 10 seconds. The duration can be changed to slow down or speed up the animation.

Slowing down an animation sometimes results in jumps from one frame to the next that were not visible when the animation played faster. It shows exactly what is present in the data. If you want this animation to play slower but still look smooth as it transitions from one frame to the other, you can apply the Temporal Interpolator filter found in the Temporal subsection of the Filter menu. This filter interpolates the data between the existing time steps, resulting in a smoother animation.

There are usually no tracks that could be edited for datasets containing time values.


File Series Animations

A dataset can also be comprised of a file series. If these files are numbered sequentially, ParaViewGeo treats the files as an animation. A file series will default to the Snap To Time Steps mode. The root file needs to be selected when the dataset is loaded.

The image shows a Lens file series comprised of three sequentially numbered files. They are all attached to a root file, Lens..vtp (the root file will always show two or more periods in front of the file extension). For the files shown here, loading Lens..vtp will load the file series and the animation can be run to cycle through the three files. In the case of the Lens series it is not a smooth transition since it just shows the lens at three different points in time.

Note: This will not work with image files. Even though the program recognizes the file series and a root file exists, selecting the root will only load the first image file. If the play button is pressed, the first texture is applied for each step of the animation but the render view will show no changes.

Since there are usually no tracks associated with file series, there are no keyframes to edit.


The Animation Inspector

The Animation Inspector is another window that can be used to work on animations. This window contains most of the same fields as the Animation View, but is arranged slightly different.

The Animation Inspector makes it easier to add tracks and keyframes since everything is located within the window without the need to open additional windows or dialog boxes. Use the Key Frame Index scroll-wheel to select which index value to change. Keyframes can also be deleted via the Inspector, but tracks can only be deleted from the Animation View.

There are three fields available in the Animation Inspector which do not exist in the Animation View; the lock options for the Start Time and End Time, and the Cache Geometry options in the Animation Settings section.

When a file containing time steps is loaded, ParaViewGeo adjusts the Start and End times to match the time steps of that file. These checkboxes can be used to lock the values so they won't be updated by the program.

The Cache Geometry checkbox determines if caching is used while an animation is playing, and the Cache Limit specifies the amount of memory available. Caching is only available for the Sequence or Snap To Time Steps modes. When caching is turned on, the geometry is stored and is used when the animation plays. If the cache limit is reached while an animation is playing, the caching option is turned off.


Rescaling a Color Map

Some datasets have properties that change over time, such as acceleration or displacement. These properties usually exist as vector arrays and can be used to color the dataset. The color map adjusts to the range of values found in the dataset when the array coloring is applied.

Sometimes when the animation is played through, the coloring is no longer representative of the data because the actual range has changed over time. Since the coloring used the range of the time step at the time it was applied, other time steps may have completely different ranges and the scale does not apply.

The Rescale to Data Range button in the Color section on the Display tab will rescale the color map to match the currently visible range. Therefore, depending on how the data changes over time, you may have to display a representative time step (usually the last) and then use the Rescale to Data Range option to set the required color scaling. Now that the appropriate range is set, replaying the animation will use the correct color map throughout.

You can also display the Color Legend so the values are visible while the animation is playing.


Saving an Animation

ParaViewGeo animations can be saved either in a movie file format or as image files. Another option is to save the geometry of the animation, or to save it as part of a project in a state file.

To save an animation in the movie file format (*.avi) or as image files, click on File > Save Animation. This will display the Animation Settings Dialog where the settings can be changed as required. The available fields depend on the animation mode, but most of the fields are filled in using the information in the Animation View. The Disconnect before saving animation option is only available when connected to a server.



For a Sequence mode, the Frame Rate, Number Of Frames and Resolution fields are available.

The Frame Rate determines how many frames are shown per second. If the number of frames per second are increased, the Animation Duration field at the top will update to show the new duration in seconds. Changing the Number Of Frames will also change the duration, but will not affect the frames of the animation. Instead, some of the frames will be skipped (if the number is lowered) or some frames will show up in duplicate (if the number is raised). With the Resolution fields you can change the number of pixels that will be used for the animation, but ParaViewGeo may change the resolution again to match format specifications and will display a pop-up showing which resolution was used.



When saving a Real Time mode animation, the Animation Duration, Frame Rate and Resolution fields are open.

The Animation Duration can be changed to increase or decrease the duration in seconds. Any changes will also affect the Number Of Frames field. The same applies to the Frame Rate. Changing the number of frames displayed per second will change the number of frames, since the animation still has to last for the duration specified. If the frame rate is increased, the number of frames will increase, but instead of interpolating frames the application will duplicate some of the frames until the required number of frames is reached. The Resolution field is again used to change the number of pixels that will be used, but the program may change the resolution to match format specifications, which will be displayed in a dialog box. 


The Snap To Time Steps mode opens the Frame Rate, No. of Frames / timestep and Resolution fields.

Changing the Frame Rate will also affect the Animation Duration. The No. of Frames / timestep field determines how many frames are displayed for each timestep of the animation. If changes are made to this value, both the Animation Duration and the Number Of Frames fields will change as required. The Resolution field is used to change the number of pixels, but the program may override the settings.
Clicking on the Save Animation button will display the Save Animation dialog box where the file location and file type are specified. Here the animation can be saved as a movie file using the *.avi format, or as image files using either *.jpg, *.tif or *.png file formats. The movie format can be played back in programs such as Windows Media Player. Using the image formats will create a separate image file for each animation frame. If multiple views exist in the View Manager, all of the views will be saved for both the movie and image formats. Neither of these formats (movie or image) can be re-opened within ParaViewGeo to allow the animation to play again.


Alternate Options

To save an animation so that it can be re-opened within ParaViewGeo, you need to use either the Save State option or Save Geometry. When saving as a state, all the coloring that is applied will be saved along with all of the actions that were performed on the datasets. However, it is difficult to share state files among several computers as the datasets must be in the same file location that is referenced in the state file.

If the animation needs to be independent of the original dataset files, the File > Save Geometry option should be used. This will save the animation in a *.pvd format which is independent of the original dataset files and can be re-opened using ParaViewGeo on any computer. The file will not save the coloring that was applied to the animation.

Multiple datasets can be saved into a single geometry file (each dataset must be selected in the pipeline prior to saving), but all objects are treated as a single multi-block object when the file is re-opened within ParaViewGeo.



Next Section Previous Section Return To
Comparative Views Stereo Controls User Manual

Comments