Documentation‎ > ‎User Manual‎ > ‎

Application Overview

Contents

Initial Layout

When ParaViewGeo is initially started, several toolbars and windows are visible by default. There are three main sections in the application:

  1. A Menu Bar is located at the top of the application to provide access to all the functions.
  2. The Toolbars are directly below the Menu Bar.
    • The default toolbars are: Main Controls, Selection Controls, Undo/Redo Controls, Camera Controls, VCR Controls, Slide Show and Center Axes Controls
  3. Docked Windows appear in the bottom section of the application.
    • Four windows are visible: Pipeline Browser, Object Inspector, View Manager, and Slide Show


Note: Although the various menus and windows are covered in separate sections, when you use the program you will frequently need to switch between the various windows to create your visualization. All the features of ParaViewGeo are designed to inter-relate with each other, and two or more may have to be used to create certain effects.


The Menu Bar

Eight menus are located on the Menu Bar in the ParaViewGeo application; File, Edit, View, Sources, Filters, Animation, Tools and Help.

The availability of the menu options depends on the data in the Pipeline Browser, with unavailable options appearing grayed out.

  • The Filters menu is initially grayed out because there is no data loaded to apply the filter to

Additional information regarding the menus is available on the Menu Bar page.


ParaViewGeo Toolbars

The various toolbars allow quick access to many of the functions.

Toolbars can be added or removed by selecting them from the View Menu; the toolbars that are currently visible have check-marks by their names. Right-clicking on any toolbar will also open a menu where the visibility can be toggled.

Additional information on the various toolbars can be accessed from the Toolbars page.

Re-arranging Toolbars

The toolbars can be re-arranged or undocked by clicking on the left side of the toolbar (where the dotted vertical line appears) and dragging the toolbar to its new location, such as the next row or floating above the windows.


Note: Toolbars that are visible when the application is closed will be visible in the same arrangement the next time the application is launched.


ParaViewGeo Windows

ParaViewGeo shows data within different types of windows.

You can add or remove windows by left-clicking on them in the View Menu; the windows that are open already have check-marks on the left of their names. Right-clicking on any toolbar will also open a menu where the visibility of windows can be toggled. A window can be closed by clicking the X in the top right corner of the title bar.

Note: Windows that are visible when the application is closed will be visible the next time the application is started, in the same arrangement.

Docking, Undocking and Re-arranging windows

The windows within ParaViewGeo can be re-arranged as required. When a window is first made visible it appears docked in the application.

Each window can be undocked by double-clicking on the title bar, or by clicking and dragging. The button that displays two windows which is on the title bar of every window in ParaViewGeo performs the same function. The window can be moved by clicking and dragging the title bar (the figure below shows the Pipeline Browser on top of the View Manager), and can be located outside the application window.

To dock the window, double-click the title bar, and it will return to its former position.

When the mouse is moved to the edge between two windows, the cursor will change to a two-headed arrow, which allows re-sizing of the window.

The windows can be re-arranged within the application by clicking on the title-bar and dragging to a new location; a blue area will appear where the window can be docked.

Note: If the blue area appears over another window and the mouse is released, a tabbed view of the windows will be created, as shown in the image below.


Resetting the ParaViewGeo layout

ParaViewGeo can be reset to the initial layout at any time. This will affect the toolbars and window panes that are visible when the program starts. Re-setting the layout may be required if a newer version of the software is installed, since the configuration file is not over-written and therefore some features may not appear without the reset.

To manually reset the layout, select Reset ParaViewGeo Layout from the Tools menu. The reset requires that ParaViewGeo be closed and restarted for the changes to take effect.



Next Section Previous Section Return To
Changing Default Settings Installing the Application User Manual

Comments