Documentation‎ > ‎User Manual‎ > ‎

View Manager

The View Manager displays render windows that show visual representations of the datasets in the Pipeline Browser. There can be several different representations of the same data in different render windows. Views can be in 3D, 2D, Bar Chart, XY Plot and Spreadsheet, as well as several comparative views.

Contents

The View Manager Menu

Each render window has icons on the menu bar which relate to functions of the window. Only those icons that relate to the chosen view are visible on the menu bar. Some of these functions are explained in more detail in later sections.


  • Undo Camera Interaction - reverses the last camera change, such as rotations, zooming and panning
  • Redo Camera Interaction - re-applies the last camera change
  • Edit View Options - opens the Render View Options where changes can be made to the background color, lights, and axes used in the active view (these settings will be applied to new windows as well)
  • Lookmark - creates a lookmark of the current view; this will save the particular view of the datasets and can be restored later
  • Adjust Camera - displays the Adjust Camera window where the camera viewpoint can be selected, the Center of Rotation and Camera Position can be manually changed, and the Camera Orientation can be varied by specific degrees
  • Split Vertically - adds a new render window to the right of the active window
  • Split Horizontally - adds a new render window below the active window
  • Maximize - maximizes the render view so it takes up all the space in the View Manager window
  • Reset - when the view window is maximized, a reset button appears that will restore the view to its former size
  • Close - closes the render window (if slides are created using this render window, they will be deleted as well)


Changing the Viewpoint

The View Manager contains numerous camera controls that will change the viewpoint of the camera, so the visualization can be viewed in various ways. Some of these controls are available through the menus and toolbars, and others are connected to mouse and keyboard controls.

The basic camera viewpoint controls can be found either in the View menu or on the Camera Controls toolbar. They control the camera location, such as looking down the positive X axis. The Reset Camera button located with these controls will zoom the camera so all visible datasets fit within the view window.


The other related controls are found on the Center Axes Controls toolbar (the functions are also in the View menu). These controls work together with the mouse and keyboard controls, because they determine the center of rotation. The Show Center icon will toggle the visibility of axes indicating where the current center of rotation is located, and the other two controls can be used to change the location of the center.


The actual interaction within the render window is accomplished by using the mouse or a combination of mouse and keyboard to zoom, pan and rotate the data. Using a mouse attached to the computer is recommended, as using a laptop touch pad mouse can be a bit tricky. The camera movement controls can be customized in the Settings found in the Edit menu.

Below are the default mouse controls for a 3D view. When a 2D view is used, the left mouse button will change the camera location by panning, and the right mouse button is used for zooming.

Note: For an XY Plot or Bar Chart view, the left mouse button scrolls the plot, the middle mouse button is used to zoom in or out of the chart, and the right mouse button is used to draw a rectangle around an area of the chart which is then zoomed. The Reset Camera button will restore the view and show the whole plot.


Zoom

There are several ways to zoom in the View Manager, depending on the type of mouse being used. One way is to use the middle mouse button and to scroll up to Zoom In and scroll down to Zoom Out. The second option is to click and hold the right mouse button anywhere in the window and then drag down to Zoom In and drag up to Zoom Out.


Pan

Panning allows movement of objects without rotation; basically you're changing the location of the camera. Click and hold the middle mouse button and drag to a location in space. Alternately, hold down the Shift key, then right-click anywhere in the render window and drag the dataset.


Rotate

Rotation is accomplished by left-clicking in the window and dragging the mouse to rotate the visualization.

The Roll feature allows rotation of the data around the center of rotation but at a restricted angle. The rotation is around an imaginary circle parallel to the screen, with the radius determined by the distance between the dataset and the center point in the 3D space. To roll the dataset, hold the Shift key and use the left mouse button while dragging.

The Yaw feature allows rotation around an imaginary circle that is perpendicular to the screen. To use this feature, hold the Ctrl key and use the right mouse button.


Undo/Redo Camera Interaction

ParaViewGeo has Undo and Redo functions that are specific to camera interactions. If any of the above changes are made to a render window, such as manually picking the center of rotation, the Undo Interaction icon can be used to reverse the change, and the Redo Interaction icon would re-apply the change. The Undo and Redo icons are only for camera interactions, so if the background color is changed on a render view, the Undo Interaction icon would have no effect, and instead the regular Undo function would have to be used.


Adding/Removing Render Windows

If the View Manager is not open, click on the View menu and select the View Manager in the lower section. The View Manager will appear, using a 3D view by default.

To add a render window when the View Manager is open, click on the Split Horizontally or Split Vertically button in the top right corner of the render window. The view will split in two, and the new window displays the list of possible views. Once a view type is chosen, the render window updates and data can be added from the pipeline. There is no limit to the number of times a render window can be split.

A render window can be removed by clicking the Close (X) button in the top right corner of the menu bar for that window. Note that if any slides were created using the view, those slides will be deleted, since they can't be reproduced if the window doesn't exist anymore.

To resize a window, move the mouse cursor to the edge of the render view until the cursor changes, and drag the window to the required size. Doing this on the outer edge of the View Manager window will resize that window; to resize a render view only, use an internal edge (one not in common with the View Manager). This can also be used to hide a window so that any attached slides will still work; drag the cursor to the View Manager edge until the window disappears. To make the window re-appear, go to that edge and when the mouse cursor changes, drag the window back out.

If multiple render views exist, only one is the active view. Changes made in the Pipeline Browser, Object Inspector, etc. will apply to the active view, so you first have to select the window where you want to make changes. Starting with version 1.4.14, the active window will blink red when first selected, and the menu bar contains the word Active.


Switching Render Windows

Once several render windows are open and displaying different visualizations, you may want to re-arrange which view appears in which location. To switch two render windows, click on the menu bar of one of them and drag it into the second window. When the mouse is released, the two windows will trade places, while keeping the sizing arrangement (i.e. if you have three windows, two small and one large and you drag the menu bar of one of the small windows to the large one, the visualization that was in the small window will appear in the large one, and vice versa).

To change the view type of a render window, right-click on the menu bar and choose the view type under the Convert-to option.


Linking Cameras

The View Manager contains a Link Camera feature that will link the camera viewpoints of two render windows. If the dataset in one of the windows is rotated, the visualization in the other window will mimic the camera movement.


To link the camera for two windows, right-click in one of the windows and click on Link Camera (or select Tools > Add Camera Link). Enter a name for the link (optional) and then click on the other render window. To add a third window, repeat the steps. Now any camera interaction made in the active window will cause the same interaction in all linked windows.

To remove a camera link, click on Tools > Manage Links. All the links are listed in the Link Manager window. Highlight the link you want to delete and click Remove, then close the window.


Docking/Undocking

The View Manager window can appear docked within the ParaViewGeo application, or it can be undocked and floating above the other windows or even outside of the application.

The View Manager window is the only one that cannot be undocked by clicking and dragging the title bar, but instead requires a double-click on the title bar. Another option is to use the Restore Down button (looks like two windows) on the right side of the title bar. Once the window is floating, it can be moved by clicking and dragging the title bar.

To dock the window, double-click the title bar, and it will return to its former position.

Full Screen/Custom Full Screen

The View Manager window can be used in two Full Screen modes to provide a larger viewing area of the visualization for demonstrations, presentations, etc. The regular Full Screen option will cause the View Manager window to re-size to the monitor’s size, whereas the Custom Full Screen option will use a specified size.

When either mode is used, the View Manager title bar disappears, but the menu bar is visible in each render window. The F9 and F10 keys are used to toggle the menu bar visibility for the active and all render views respectively.

To enter the Full Screen mode, use the F11 key on the keyboard. The same key is used to exit full screen mode.

For the Custom Full Screen mode, the height and width of the window, as well as the position on the screen can be entered on the Full Screen Controls toolbar. The F8 key on the keyboard is used to toggle between the Custom Full Screen and Normal mode.

See the Hot Keys page for additional keyboard shortcuts. These are especially useful when using the full screen mode.


Spreadsheet Options

One of the possible view types for the render windows is the Spreadsheet view, which shows a numeric representation of the dataset selected in the Pipeline Browser. Only one dataset can be viewed at a time.

The top of the view contains two drop-downs for Showing and Attributes. The Showing drop-down lists all the datasets available in the Pipeline Browser. The Attributes drop-down lists the data type that can be viewed; Cell Data, Point Data and Field Data. Depending on the dataset selected, not all attribute options will contain information.


Selecting Data

If two render views are open, one to a 3D visualization and the other to a spreadsheet view of the same datasets, selecting data in one window will identify that data in the other. For instance, if several rows are selected in the spreadsheet view, those points are identified in the 3D view. This also works vice versa if data is selected in the 3D view using the Select Cells and Points options as mentioned above, the corresponding rows are highlighted in the spreadsheet. The screenshot shows this correlation.



While the Spreadsheet is the active window, the Display tab of the Object Inspector changes. The Show Data checkbox toggles the visibility of the dataset information in the spreadsheet. If one or more rows are selected in the spreadsheet, the Show only selected elements checkbox will shorten the list to show only those rows. Note that when a narrowed list is displayed, the Point Coordinates column disappears. The third option to Select Attributes to Show performs the same function as the Attributes drop-down in the spreadsheet window; you can select Cell Data, Point Data or Field data as the data type.

Depending on the type of data selected, additional options may be available. Some are covered on the Dataset Properties page.


Exporting Data

The information displayed in the spreadsheet view can be moved to Excel or another spreadsheet application so the data can be examined more easily. It is possible to copy a single row of data, multiple rows or all the data in the table.

To copy a single row, click on any cell in the row, then right-click and choose Copy. To select multiple rows, click in the first row and drag the mouse to highlight the required rows. If the rows are not next to each other, hold down the Ctrl key and highlight each row of data. Once all required rows are highlighted, right-click and select Copy. To copy all the data in the spreadsheet, right-click in any cell and choose Select All. Depending on the quantity of data, it may take a few seconds to highlight all cells. Once the data is highlighted, right-click and select Copy.

Switch to Excel and choose Paste from the Edit menu, or use Ctrl+V to paste the data. Note that the column headings are not copied over.

Please Note: This functionality was available until version 1.4.12, but has been removed due to issues with the number of rows being copied. It is under development, and will be re-added in a future version. In the interim, a single row can be copied using the Ctrl+C keyboard function.



Next Section Previous Section Return To
Selecting Data Statistics View User Manual

Comments